menu Chancel's blog
rss_feed
Chancel's blog
秋雨一何碧,山色倚晴空。

我的笔记

搜索
列表(176)
Windows11如何添加中文输入法
类型:Windows

Windows11如何添加中文输入法

更新于 2022-05-22 13:39:11
创建于 2022-05-22 13:39:11

Windows11如何添加中文输入法

Windows10.gif

VSCode在launch.json中自定义Python解释器位置
类型:Python

VSCode在launch.json中自定义Python解释器位置

更新于 2022-05-19 10:56:23
创建于 2022-05-19 10:54:43

VSCode在launch.json中自定义Python解释器位置

python": "${workspaceRoot}/src/server/.env/bin/python3

Windows11 右键显示所有功能菜单
类型:Windows

改变Windows11恼人的右键菜单

更新于 2022-05-13 01:06:45
创建于 2022-05-13 01:06:45

Windows11 右键显示所有功能菜单
reg.exe add “HKCU\Software\Classes\CLSID\{86ca1aa0-34aa-4e8b-a509-50c905bae2a2}\InprocServer32” /f
Flask 静态资源(JS/CSS)添加版本号
类型:Python

为Flask的静态资源如CSS/Javascript文件添加版本号

更新于 2022-05-12 15:47:19
创建于 2022-05-12 15:47:19

Flask 静态资源(JS/CSS)添加版本号

为了建立资源文件与文件内容的关系,可以利用Flask中的Registering Filters功能来实现,首先对Flask模板渲染文件做以下更改

// 修改前
<script src="{{ url_for('static', filename='js/vue.min.js')}}"></script>
<script src="{{ url_for('static', filename='js/mdui.min.js')}}"></script>

//修改后
<script src="{{ url_for('static', filename='js/vue.min.js')|autoversion}}"></script>
<script src="{{ url_for('static', filename='js/mdui.min.js')|autoversion}}"></script>

“autoversion”方法可以在Flask中实现如下

@app.template_filter('autoversion')
def autoversion_filter(filename):
  fullpath = os.path.join(app.root_path, filename[1:])
  try:
      timestamp = str(os.path.getmtime(fullpath))
  except OSError:
      return filename
  newfilename = "{0}?v={1}".format(filename, timestamp)
  return newfilename
Docker下Openwrt与宿主机网络通信
类型:Network

设置Docker容器中的Openwrt与宿主机进行网络通信

更新于 2022-05-09 01:14:18
创建于 2022-05-09 01:14:18

Docker下Openwrt与宿主机网络通信
# 网桥名称为openwrt-macvlan
/usr/bin/ip link add openwrt-macvlan link eth0 type macvlan mode bridge
# 为该网桥分配IP为192.168.11.12
/usr/bin/ip addr add 192.168.1.12 dev openwrt-macvlan
# 启动网桥
/usr/bin/ip link set openwrt-macvlan up
# 为宿主机添加静态路由通过创建的网桥来访问openwrt
/usr/bin/ip route add 192.168.11.11 dev openwrt-macvlan
Docker运行Openwrt旁路由无法联网问题解决
类型:Network

Openwrt旁路由域名解析与PING均正常却无法转发其他设备请求

更新于 2022-04-29 00:48:04
创建于 2022-04-29 00:48:04

Docker运行Openwrt旁路由无法联网问题解决
/ # cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd13:c13b:3718::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.100'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'
        option _orig_ifname 'eth0' # Openwrt有时保存后会丢失该项,可手动填入并重启网络
        option _orig_bridge 'true' # Openwrt有时保存后会丢失该项,可手动填入并重启网络
        option ifname 'eth0'
Linux LVM分区扩展分区大小
类型:Linux

Linux LVM分区使用LVM与resize2fs命令工具扩展分区大小

更新于 2022-04-24 14:55:55
创建于 2022-04-24 11:53:47

Linux LVM分区扩展分区大小

操作步骤

sudo lvm
    >> lvextend -l +100%FREE /dev/mapper/ubuntu--vg-ubuntu--lv
    >> exit

sudo resize2fs /dev/mapper/ubuntu--vg-ubuntu--lv
Kde设置Meta(Windows)打开桌面菜单
类型:Manjaro

Kde设置Meta(Windows)打开桌面菜单

更新于 2022-04-24 11:04:16
创建于 2022-04-24 11:04:16

Kde设置Meta(Windows)打开桌面菜单

KDE桌面设置桌面快捷键时不小心覆盖了Meta键的热键设置,在桌面按Meta无法唤出Dock栏的菜单了

右键Dock栏的菜单,在 Configure Application Menu -> Keyboard Shortcuts 中设置快捷键为 Meta+F1 即可恢复,如下图

DeepinScreenshot_select-area_20220424030159.png

iperf 网络带宽测试工具
类型:Software

测试网络设备之间的带宽质量、网络抖动

更新于 2022-04-19 16:27:17
创建于 2022-04-19 16:19:50

iperf 网络带宽测试工具

下面以测试本地到服务器(104.160.18.230)之间的网络质量

在104.160.18.230上安装iperf并运行

sudo apt install -y iperf

iperf -s -p 55201

参数解释

  • -s 服务端
  • -p 指定端口(默认55201)

在本地的Ubuntu1804机器上安装iperf并运行

sudo apt install -y iperf

iperf -c 104.160.18.230 -t 30s -i 1s -p 55201

参数解释

  • -c 客户端运行
  • -w tcp 数据包大小
  • -t 测试时间
  • -i 刷新时间
  • -p 服务端接收的端口
Linux下挂载SMB文件夹(共享文件夹)
类型:Linux

Linux下挂载Windows共享文件夹(Samba协议)

更新于 2022-04-08 12:09:12
创建于 2022-04-08 12:08:05

Linux下挂载SMB文件夹(共享文件夹)

挂载命令

sudo mount -t cifs -o credentials=/etc/samba-credentials  //[ip]/[directory] /mnt/[directory]
使用AAPT获取软件的包名与启动Activity
类型:Android

Manjaro下使用AAPT获取软件的包名与启动Activity

更新于 2022-04-07 18:29:06
创建于 2022-04-07 18:23:02

使用AAPT获取软件的包名与启动Activity
[Android SDK Path]/build-tools/32.0.0/aapt dump badging DingTalk.apk
Ubuntu1804安装Oh-My-ZSH
类型:Linux

Ubuntu1804安装Oh-My-ZSH

更新于 2022-04-06 11:02:37
创建于 2022-04-06 11:02:37

Ubuntu1804安装Oh-My-ZSH
sudo apt-get install -y zsh git

sh -c "$(wget -O- https://gitee.com/shmhlsy/oh-my-zsh-install.sh/raw/master/install.sh)"
1 of 15 | A total of 176